Back to overview
Downtime
Our hompage is not available
Feb 20 at 09:07am HST
Affected services
lettr.com
Resolved
Feb 20 at 09:12pm HST
This incident has been resolved.
Affected services
Updated
Feb 20 at 10:43am HST
Update - They are actively working with their partners to restore service and will provide another update once recovery is complete.
Affected services
Created
Feb 20 at 09:07am HST
Our hompage hosted on Laravel Cloud is impacted by availability of Laravel Cloud Services. All other services like App and API are running normally.
We are following: https://status.laravel.cloud/
Sorry for inconvenience.
Affected services